vpnc on Ubuntu Oneiric: “Error: either “to” is duplicate, or “ipid” is a garbage.”

When one attempts to connect to their VPN after installing and configuring vpnc on Ubuntu Oneiric, the following error occurs:

root@ubuntu:~# vpnc-connect 
Error: either "to" is duplicate, or "ipid" is a garbage.

After some time it eventually times out and fails to create a connection.

vpnc version information:

root@ubuntu:/tmp# vpnc --version
vpnc version 0.5.3
Copyright (C) 2002-2006 Geoffrey Keating, Maurice Massar, others
vpnc comes with NO WARRANTY, to the extent permitted by law.
You may redistribute copies of vpnc under the terms of the GNU General
Public License.  For more information about these matters, see the files
named COPYING.
Built with certificate support.
 
Supported DH-Groups: nopfs dh1 dh2 dh5
Supported Hash-Methods: md5 sha1
Supported Encryptions: null des 3des aes128 aes192 aes256
Supported Auth-Methods: psk psk+xauth hybrid(rsa)

It appears that the Ubuntu package vpnc comes with an old version of vpnc-script. This script is what sets up all the addresses and routes for you. The OpenConnect project provides an updated / revised release of this script. Download the latest copy from here . Replace the vpnc-script script that comes with the Ubuntu vpnc package: /etc/vpnc/vpnc-script.

References